Jump to content
Stray Fawn Community
Sign in to follow this  
DethLazrs4Lyfe

NOT gate "always on" on planet

Recommended Posts

Running version 0.3.2
Possibly related to Aevus's post about NOT gates below


I was trying to make a little mining drone that activates once the distance sensor stops activating (see very crudely drawn explanation on screenshot) It works exactly as anticipated in the testing area, but once I got to the planet to test, the drone immediately activates, as if the NOT gate is activating B even though the distance sensor (A) is still detecting the drone above it.

logic error 01.PNG

Nimbatus_GIF_201807080958372159.gif

Nimbatus_GIF_201807080958591073.gif

  • Like 1

Share this post


Link to post
Share on other sites

Mhh strange, can you upload the drone file so we can test it out? 

Share this post


Link to post
Share on other sites

UPDATE:
Taking it straight up seems to reliably fix the issue
I'm pretty sure bumping the Nimbatus does it. I'm on repetition 5 and this has worked every time. Hovering just below the ship doesn't seem to help.
Edit: Alternate hypothesis is that the impact knocks the sensors out of alignment, and that quick toggle resets it. I'm unable to repeat this "fix" with a single central sensor (like in the drone file I sent.)

Nimbatus_GIF_201807081042475126.gif

  • Like 1

Share this post


Link to post
Share on other sites

@DethLazrs4Lyfe The problem was that if the distance sensor is detecting something while the game is still loading it does not fire the event unless it gets triggered again.

Will be fixed in a patch later today :)

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×