Jump to content
Stray Fawn Community

Crashes when I try to play on my Desktop

Recommended Posts

Running v. 0.6.3 Steam Early Access
Some Context
I bought the game on steam just a few days ago and was playing on my laptop (MSI GL73; Win. 10 x64, Intel i7 8th Gen 2.2 GHz, 16GB RAM, GTX 1050) just fine and it was great. However, when playing the game I noticed that my laptop got pretty hot. For a while as long as it worked, which it did, I didn't care. however I noticed that my power block was especially hot, too hot to hold so I got concerned and I unplugged my laptop & closed the game but not too long later noticed my battery had 28% and 9 minutes left. 
TLDR; My laptop got hot so I tried to use my desktop
It may or may not be relevant that Steam had synced all the game data. 
When I started the game on my desktop (Win. 10 x64, Intel i7 3.6 GHz, 48GB RAM, RX 480), it seemed fine; the game main page showed up, settings page works etc. Trying to go into the tutorial, continue a previous game, or start a new game all crash or freeze the game though.



From a user perspective, this is awful. There's nothing too abnormal about my Desktop as far as I'm aware that would cause this kind any kind of unexpected issue yet the game is rendered completely unplayable on it. 

My attempts to troubleshoot
First off, not every crash resulted in a new error.log file.
In the error.log file I did have, the last thing it said was

Module 1
Image Base: 0x727c0000  Image Size: 0x00c93000
File Size:  12989960    File Time:  2017-10-13_112352
   Company:    Advanced Micro Devices, Inc. 
   Product:    Advanced Micro Devices, Inc. Radeon Video Acceleration Universal Driver
   FileDesc:   Radeon Video Acceleration Universal Driver
   FileVer:    22.19.677.257

Which I'm going to assume means this is the file which caused the error prompting the file creation. From what I can tell this is a file directly related to my GPU drivers, based on the fact it says `Radeon Video Acceleration Universal Driver` in the file description. I didn't recall ever updating the GPUs drivers so I figured maybe trying to update my AMD dirver would help.

Trying to start a new game, I got further and it didn't crash, it just froze and softlocked on the "this is still an early access game" screen, and wouldn't refit the (frozen) graphics on window resize. It also went crazy, writing data to the log file getting over 50 MB before I noticed. I uploaded it with a bunch of repetition removed (7 KB).

Trying again, I got this WattMan error:


Same thing when trying to do a tutorial mission:

I proceeded to uninstall and reinstall the game, trying to open a tutorial mission after that provided a true crash.



I've tried a plethora of other little things to try and trouble shoot this but most of them resulted in one of the errors mentioned above and I've had to restart my computer more times than I can remember. 
Also, both Golf With your Friends and Kerbal Space Program (both Unity games) work fine.


output_log.txt crash report.zip

Link to post
Share on other sites

More troubleshooting attempts notes:
I tried downloading the demo on my desktop to see if it worked and it works just fine.
As does 0.2.4 on Steam, but 0.3.2 does no, it crashes before it finishes loading the game similar to how the current build crashes.

Link to post
Share on other sites

@Edward We upgraded the engine with the last update, so this might explain why the older versions work.
According to the logs it looks like unity has trouble with your graphic card drivers. There are alot of instances of this error: DXGI_ERROR_DEVICE_REMOVED
I have to research what the causes of this error are. In the mean time I would try the following things:

  • Make sure the laptop is not in power saving mode
  • Disable all screen space effects (bloom and AA) and check if the game still crashes
  • Reinstall graphic card drivers
  • Check if it makes a difference whether the game runs in full screen or windowed mode

We plan to release a preview version of the next update later this week, it uses again an upgraded version of unity, so it would be good to see if the crashes still happen there.

Link to post
Share on other sites

Disabling Bloom/AA/Full-screen makes no noticeable difference, it still either crashes or hangs when trying to play a tutorial level.

It was the same problem both before and after updating my graphics drivers (as described above) so I don't see how that could be the problem.

While looking around I found the same issue reported on another game: https://github.com/StrangeLoopGames/EcoIssues/issues/11125




Link to post
Share on other sites

I was correct, lowering the resolution to the smallest size I could still click things worked, I could place stuff but then I tried resizing and immediately after, it froze.

In addition to that, I noticed that all the `(a x b fmt c aa d), error 0x887A0005` errors only happen AFTER it freezes and only when I try to resize the window and I believe it's similar with he other 0x887A0005 errors. 

I'm guessing some trigger is being hit (maybe some section of memory getting full?) which causes a failsafe to trigger resulting in the 0x887A0005 errors (but the DEVICE_REMOVED isn't the cause, it's the result)


Link to post
Share on other sites

I jus t tried 0.7.0 and it didn't fix the issue. I could go into the campaign, see dialogue and pick a captain but nothing past that. 

I also couldn't go into the competitive editor without it freezing and same goes for the tutorial.

of the attempts I made, only 1 crashed the game, the rest froze it (and freezing doesn't give a crash dmp) so I included that one. If you want me to try anything else just ask.

output_log.txt crash.dmp error.log

Link to post
Share on other sites

Ok unfortunately the only thing I can do with the crash.dmp is forward it to the unity guys as I don't have the engine source and it's a unity crash.
 However I stumbled across another thread while searching for the error. 

You could try to disable the steam overlay or change some compatibility settings, maybe this helps:


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...